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Licensing: 

Trust licensing is implemented with SELECT Server XM meaning that a continuous 

connection to the license server is no longer needed. License activation is upon 

installation and only requires a connection once every 30 days. Licensing registration is 

now stored in the registry. 

 

User Interface: 

The Main tool box partially replaces the Main tool frame. The Main tool box has fewer 

child icons, appears as one column in the application window, and contains only 

modification tools. The traditional Main tool frame is available from Tools > Tool Boxes 

<Ctrl+T> > Main Classic. 

 

 
 

Tools > Task Navigation tool box is designated by the inclined plane which shows task 

lists to associate tools with tasks and contains only creation tools formally accessible 

from the Main tool frame. A task is a set of tools grouped to facilitate a workflow, 

contains references to tools and tool boxes, and can be application- or user-defined. 

 

 
 

Right-click support available for any tool frame or tool box to enable/disable icons. 

<Shift+right-click> in an open view provides access to view menu pop-up.  
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Window > Task Navigation in Views off by default so only one task is active at a time 

and if enabled, will dock the task navigation tool box to each window enabling different 

tasks to be started in different views. 

 

 
 

A managed focus model is implemented with a top level called home with additional 

input focus status shown in the status bar. <Esc> sends focus home and positional 

keyboard navigation can be used. 

 

 
 

Positional keyboard navigation maps keys to interface items and is enabled by 

Workspace > Preferences… > Position Mapping > Use Position Mapping. 

 

 
 

In the home state: 

<Enter>    opens the command browser at the cursor 

<Spacebar>    moves focus to AccuDraw 

<Tab>     cycles through overlapping elements 

<Shift+position map>  starts the tool shown and the menu will not be displayed 

 

Workspace > Preferences… Look and Feel > Tool Size controls the size of icons in 

undocked tool boxes. 

 

Workspace > Preferences… Look and Feel > View Tool Size controls the size of icons in 

tool boxes docked to open windows. 
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Workspace > Preferences… > Look and Feel > Transparent dialogs become opaque 

when receiving focus off by default. 

 

Workspace > Preferences… > Look and Feel > All modeless dialogs use same 

transparency off by default. 

 

 
 

Workspace > Preferences… > View Options > Show View ToolBox contains a drop-

down version of View Attributes. 

 

 
 

 
 

Right-click in view for context sensitive menus: 

<Shift+data>  pan scroll 

<Shift+reset> context sensitive pop up for quickset and view control 

 

PopSet: 

1. Properties > Hide Border (pixels) defines a margin around Tool Settings so the 

dialog will disappear when the cursor is within the margin. 
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Element Selection Incorporates Power Selector Functionality:   

1. Should be started in method: individual and mode: new so that newly selected  

elements will deselect previously selected elements. 

 

 
 

2. Provides support for element templates.  

3. <Right-click> on an element with element selection active provides contextual 

element manipulation shortcut. 

 

Drag-and-Drop Operations with Selected Elements:  

1. <Ctrl+drag> will copy an element instead of move.  

2. To change the active attributes to match the attributes of an existing element, 

drag the element to the Attributes tool box and drop it on the icon for the 

setting, or drop it on the Symbology Preview box to change all the settings. 

       

 
 

Element Manipulation Using Handles: 

1. Use <Ctrl> to select multiple handles individually or with a window to lock 

specified handles.  

2. Use handles to modify the clip boundary of a reference file. 

 

Element Information: 

1. Dockable and stackable by dragging the title bar onto the title bar of other 

dockable dialogs like Level Display for tabular display. 

2. Properties update as elements are selected and deselected. 

3. A group of elements can be placed into a selection set and changed from non-

snappable to snappable. 

4. Can be customized with right-click. 

 

Tools > Attributes has three additional icons, Active Element Template, Active Element 

Transparency, and Active Element Priority. 
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Element Templates: 

1. Define element properties that can be used to set the active settings for element 

placement or be applied to existing elements. 

 

  
2. Elements can contain a reference to a template. Placing an element with a 

reference to a template adds the template to the file if it is not already in the file. 

3. Combine a standard with a tool and stored in a DGNLIB. 

4. Local templates will resymbolize automatically when the template is modified.  

 

Element Transparency: 

1. Applied to individual elements, references, and levels and controlled from View 

Attributes > Transparency. 

 

  
2. Effective transparency is (1- (element transparency)*(level 

transparency)*(reference transparency)). Element Info does not report effective 

transparency. 
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Element Priority: 

1. Corresponds to depth in 3D and only available in 2D. 

 

  
2. References with a priority of zero will appear above elements in the active file. 

References with equal priority will resort to level priority for sorting of graphics. 

3. Levels with a priority higher than another level will appear above the element 

with the lower level priority. Levels with the same priority will resort to element 

priority. 

4. Elements with the same reference and level priority, but higher element priority 

appear above elements with lower element priority.  

5. Effective priority is (ref priority*1000000)+(level priority*1000)+(element 

priority*1). 

6. In general, negative values are used to make references, levels, and elements 

appear under all other elements. 

 

Display system is faster and smoother based on Microsoft DirectX: 

1. Display priority specifies the front-to-back order for 2D elements and can be 

assigned to elements, levels, and references. 

2. Transparency can be set for elements, levels, and references. 

3. Levels and references can be sorted based on display priority, transparency, or 

any other column. 

4. Immediate healing of elements when graphics are deleted. 

 

Workspace > Preferences… > View Options > Dynamics Transparency sets amount of 

transparency used to display elements in dynamics. 
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Workspace > Preferences… > View Options > Auto-Locate Transparency sets the 

amount of transparency in the highlight color used to flash elements for auto-locate. 

Opaque shows the highlight color. Clear shows less of the highlight color and more of the 

element color. 

 

 
 

Color: 

1. Active color can be specified by a standard 256 color table, true colors like RGB 

and HSV, and color books. A color book is a container for a collection of named 

colors.  

  
 

2. Includes availability of PANTONE, a standard for publishing, RAL colors, and 

gradient fills.  

3. Gradient fill is available when fill type is opaque or outlined and takes multiple 

colors and interpolates them across the surface of a filled element. Gradient fills 

can be applied directly to elements or element templates. Handles are used to 

adjust the gradient and are added by changing Color Mode to Multiple colors. 

Handles are deleted by selected the top portion and striking the delete key.  
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Fence: 

1. Multiple named fences can now be created and recalled. 

2. Array added as a Fence Manipulation and works identical to Construct Array by 

showing only one instance in dynamics and the rest as dots. 

3. AccuSnap disabled by default for fence creation but can be enabled from 

AccuSnap > Settings > General > Enable for Fence Create.  

 

Text: 

1. Right-click in the Text Editor window contains items for cut <Ctrl+X>, copy 

<Ctrl+C>, and paste <Ctrl+V>. 

2. Workspace > Preferences… > View Options > Anti-alias Text controls the 

display of TrueType fonts at various zoom levels. 

 

  
 

Place Note: 

1. Settings are now included with Dimension Styles. 

2. Leader Type: Curve to distinguish notes from other annotations. 

  
 

 

3. The same graphic group number is now assigned to all elements in the currently 

placed note so only one data point is needed to delete or move. 

4. Use <Ctrl> for multiple leaders from a single leader location. 
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Fields: 

1. Can be inserted as text is placed or edited with a right-click in the Word 

Processor. Field content can be derived from element attributes, properties of the 

active model, or properties of the open file.  Fields based on element attributes are 

automatically updated when the element is changed. Fields based on model or file 

properties are updated when the file is opened. 

2. Workspace > Preferences… > Text > Hide Field Background. 

 

  
 

Levels: 

1. All new levels inherit properties of the default level.  

2. Cells created on the default level with by ByLevel attributes can then be placed 

relative to the active level. 

3. Can now drag Level Manager dialog column headings into a different order. 

4. Right-click the level map in Level Display for level on|off options and access to 

Level Manager. 

 

Line Styles: 

1. Custom line styles can be stored in DGNLIBS by importing resource files from 

the Line Style Editor. 

2. Settings > Design File… Element Attributes > Global Line Style Scale applies to 

references also. 

 

Models: 
1. The active model is displayed in each view window’s title bar. 

2. Right-click on a model in the Models dialog to open, copy, rename, and get 

properties. 

3. Associate border attachment with sheet model so any changes to the annotation 

scale will be reflected in the border attachment with key-in: sheet set 

borderattachment <bordername>. 

4. Key-in: newsession <filename>, <modelname> to open a specified file in a new 

session. 

5. History navigation from View Groups > Previous Model, Next Model, and All 

Models Visited are for the current session only. 
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Reference: 

1. For a reference move, Tool Settings > Move Boundary with Reference on will 

move clip boundaries and masks with the reference.  

2. Using an element instead of a fence for clipping operations has several 

advantages. If the clipping element is in the active file, it can be modified or a 

vertex can be added/deleted to change the clip area. If in another reference, the 

clipped reference may be panned behind the clip element. 

 

  
 

3. From element selection pop-up, right-click on an element in a reference allows 

reference exchange and view settings are preserved if the file is attached 

coincidently. 

 

More right-click support: 

1. Right-click an attachment in the References dialog for open, attach, and detach 

options. Show|Hide columns of information by right-clicking the column for 

heading. The logical column is either the master or the reference logical name.  

2. Reference dialog now includes reference tools and a drop-down list. All icons 

have equivalent right-click options when the reference is highlighted. 

3. Any nested reference (i.e. a reference that is not attached directly to the active 

model) can be promoted to a top-level reference by right-clicking the nested 

reference in the References dialog box and selecting "Make Direct Attachment" 

from the pop-up menu. 

 

Attachment Settings:  

1. Manipulate as Element allows references to be manipulated as elements with 

move, rotate, copy commands. 

2. Attachment settings for orientation include named fences. 

 

Raster Manager: 

1. Raster attachments are automatically assigned to the active level. 

 

Generating PDF: 

1. File > Print > Bentley driver > ..\workspace\system\plotdrv\pdf.plt to create PDF 

output.  

2. Edit > Insert Object > Create from File and browse to PDF to embed PDF. 
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Standards Checker: 

1. Can generate a report listing differences and interactively walk through the file 

with the option to ignore, fix, or skip non-compliant elements. 

2. Settings can be defined for levels, text styles, dimension styles, element 

templates, and line styles. 

3. Can be run on individual files or as a batch process. 

 

Project Explorer: 

1. File > Project Explorer supersedes Engineering Links and shows link sets that are 

used to organize project data.  

2. Link sets are stored in the DGN file and contain links to DGN files, DWG files, 

design and sheet models, references, saved views, and documentation in other 

formats like PDF, Word, and Excel. 

 

Working with DWG: 

1. Direct read, write, and reference of DWG is extended to AutoCAD 2006. 

2. All Open and Save As… options are stored in DwgSettings.rsc. 

 

DWG Open Options: 

 
 

1. Basic > Architectural or Engineering Units: LUNITS are the closest concept to 

working units. This setting specifies how MicroStation handles different units or 

either defers the units to a seed file or Design Center Units. 

2. Basic > Decimal, Scientific or Fractional Units: Design Center Units will use the 

value of INSUNITS.  

3. Basic > Decimal, Scientific or Fractional Units > Unspecified Design Center 

Units value used if INSUNITS = 0. 

4. Basic > Preserve MicroStation Settings on will save active angle and active 

scale to an XRECORD if the file may be opened again in MicroStation. 

5. Basic > DGN Seed File will use MS_TRANSEED, the default translation seed. 

MicroStation converts DWG to DGN using this seed file in the background and 

then saves it back to DWG when it is closed. 

6. Basic > Model Space > Create 2D Models for Model Space on will open DWG 

as 2D. 

7. Basic > Model Space > Design Background Color sets the background color for 

model space. 
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8. Basic > Paper Space > Create 2D Sheets for Paper Space creates flat sheets for 

paper space. 

9. Basic > Paper Space > Sheet Background Color sets the background color for 

sheet models created from paper space layouts. 

10. Advanced > Use Seed File Global Origin on will use the GO location from the 

translation seed file. Leave this off unless you have problems with the location of 

coordinates. 

11. Advanced > Set Axis Lock if Orthomode = 1 on will enable Axis lock.  

12. Advanced > Map Logical Names to XRef Block Names on will map the 

reference name of the XRef to the logical name in MicroStation.  

13. Advanced > Discard Invalid Entries on only affects a file when saved and 

checks for abnormally large elements and deletes them. Rarely needed and a 

better option is to Audit and Recover…  

14. Advanced > Hyperlink as Engineering Link should be on only if hyperlinks 

need to be edited.  

15. Advanced > Graphic Group Block Attributes on will place attributes in a 

graphic group and turn on Graphic Group lock so tags can be moved as one set.  

16. Advanced > Proxy Objects Display Mode > 1-Show Proxy Image default will 

display graphic images for all proxy objects.  

17. Advanced > Default Line Weight sets line weight to a physical size or reads 

LWDEFAULT if set to From AutoCAD Registry.  

18. Advanced > Proxy Display View sets the orientation of the proxy graphic.  

19. Advanced > Display Units Alert allows proper units to be chosen when 

MicroStation cannot infer the units. If Do not display again is unchecked and 

causes problems, it can be retrieved by closing the file and re-enabling the option 

before opening the file again. 

20. Advanced > Default Line Weight > From AutoCAD Registry is recommended. 

21. Advanced > Proxy Display View > Isometric is recommended to maintain a 3D 

view in a 3D file.  

22. Advanced > Display Units Alert all on is recommended. 

23. Advanced > Rendering all on for MicroStation to read DWG rendering data. 

24. Line Weights apply to both open and save and the recommendation is to match 

DWG weights in the plot driver.plt. All settings match the AutoCAD environment 

exactly. No changes recommended. 
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Save As DWG/DXF Options: 

  
 

1. General > Basic > DWG Version should be the most current version. 

2. General > Basic > Level Display specifies which view’s level display will be 

exported. MicroStation will convert all levels regardless of whether they are on or 

off.  

3. General > Basic > Units:Master is recommended and are the units written to the 

resulting file. 

4. General > Basic > Line Code Scale (Design Units/Cycle):0:0.000 cannot be 

applied globally because LTSCALE depends on the final scale of an individual 

drawing. Recommended value is zero and use keyin “active linestylescale 

<value>” which is equivalent to \LTSCALE to set final scale. 

5. General > Basic > Use Level Symbology Overrides on will use Level Manager 

overrides instead of ByLevel attributes. If no overrides exist, ByLevel settings 

will be used even if this is on.  

6. General > Basic > Preserve MicroStation Settings is shared by both Open and 

Save As and allows certain file settings to be retained when DWG does not 

directly support them. 

7. General > Basic > DWG Seed File:seed.dwg uses a translation seed file to define 

certain settings that do not exist in the DGN i.e. linestyle scale will set LTSCALE 

and a sub unit value of mm will set LUNITS = 2. The translation seed should be a 

standard DWG/DWT file. Settings from the DGN, translation seed, and 

DwgSettings.rsc are all used to create the final DWG. 

8. General > Advanced > Drop Unsupported Line Styles on will drop line style 

and display correctly in DWG. 

9. General > Advanced > Display True Color From DGN Color Indices on will 

map colors exactly to the DWG RGB value.   

10. General > Advanced > Convert Empty Enter-Data Fields to Spaces 

recommended off and converts empty EDFs to spaces “ “ or underscores “_” . 

11. General > Advanced > Set UCS From Current ACS on by default will rotate the 

coordinate system in DWG to match MicroStation’s ACS. Off will still convert 

the ACS but the coordinate system is left as World. 
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12.  General > Advanced > Save Front and Back Clip Planes on saves clipping 

planes for a 3D file. Recommendation is to export only desired portion of file 

rather than save clipping planes or export a clip volume. 

13. General > Advanced > Force Positive Extrusion of Clockwise Arcs is a 

redundant setting. Recommendation is off. 

14. General > Advanced > DXF Precision (Decimal Places): 0.12345 leave as 

default and avoid DXF. 

15. General > Advanced > Non-Default Design Models:Create Separate Files 

default, safest and most flexible creates a new DWG for every model. Ignore if 

Not Merged will leave out all non-default models. 

16. General > Advanced > Create Separate Files for Sheets off by default. If on will 

create separate DWGs for each sheet. 

17. General > Advanced > Polyface Mesh Tolerance Angle: 30.00 controls facet 

angle of surfaces in a mesh. 

18. General > Advanced > Force Zero Z-Coordinate off by default. If on will flatten 

3D DGN info to 2D at AZ = 0. Recommendation is to leave this off except when 

a 3D file contains only 2D info. 

19. General > Advanced > Use Level Display for Viewport Freeze Only 

recommended off if using a view for export. 

20. General > Advanced > Application Data > Save Application Data stores non-

graphic info if the file will be brought back into DGN. 

21. General > Advanced > Rendering saves materials and light sources to DWG. 

22. General > References > Create Overlays for References (No Live Nesting) off 

by default. On will save the file with no nesting (overlays) and appropriate when 

saving V7 files to DWG or for a file with live nesting disabled for all attachments. 

23. General > References > Save Path: When Saving to Same Directory retains the 

complete path only when the output directory is the same as the source DGN.  

24. General > References > Map Logical Names to XRef Block Names on by 

default and will map XRef names to MicroStation logicals. Off will leave the 

logical blank. 

25. General > References > Set Viewport Layer from Clip Element off by default, 

but when enabled the layer for a viewport will be set to match the layer of the clip 

element. 

26. General > References > Set Viewport Locked From Locate Off off by default, 

but when enabled will lock a viewport by turning off locate. 

27. General > Line Weights should be specified in the plot driver. 

28. General > Entity Mapping > Planar Line Strings: Polyline default specifies the 

end result of a flat 2D line. 

29. General > Entity Mapping > Non-Planar Line Strings: 3D Polyline default 

specifies the end result of a flat 3D line. Recommendation is to leave defaults. 

30. General > Entity Mapping > Flat Solids and Surfaces: Polyface Mesh. 

Recommendation is to leave default. 

31. General > Entity Mapping > Curved Solids and Surfaces: ACIS Entity (Body 

or 3D Solid). Recommendation is to leave default. 

32. General > Entity Mapping > Curves and B-Spline Curves: Spline Entity. 

Recommendation is to leave default. 
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33. General > Entity Mapping > Filled Elements, 2D Unfilled Elements, 3D 

Unfilled Elements. Recommendation is to leave default. 

34. General > Classes > Construction Class Elements: Save to “Construction” 

Layer creates layers in the DWG with the same name as the original DGN but 

with “Construction” added to the end. 

35. General > Classes > Pattern Class Elements: Save default to avoid large 

amounts of duplicated layers. 

36. General > Classes > Linear Patterned Class Elements: Omit. Recommendation 

is to leave default. 

37. General > Classes > Create Single Block for Duplicated Cells on by default will 

avoid many copies of the same cell for different scales. 

38. General > Classes > Create Scaled Blocks on by default. Recommendation is to 

leave default. 

39. General > Classes > Insert Layer for Normal Cells to specify a layer for cells on 

the default level to be converted to. 

40. General > Classes > Cells > Create Block Entities with “ByBlock” Properties 

allows cells to be converted with ByBlock properties. 

41. General > Fonts > Code Page for DWG File: English-1252 sets the DWG file to 

a different character set for special symbols. Recommendation is to leave default. 

42. General > Fonts > Text Style Name Template: Style-%s default prefixes “Style-

“ to the text style. 

43. General > Fonts > Convert MicroStation Fonts to AutoCAD Fonts on by 

default converts fonts in font.rsc to SHX in the SHX Output directory. 

44. General > Dimensions > Save Active Dimension Settings on by default converts 

active dimension settings to AutoCAD dimension style overrides. 

45. General > Fonts > Always Create an In-Line Leader for Notes off by default. 

On will force notes to have a leader. 

 

 

 

 

 


