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Course Overview

In this course you will be creating the horizontal and vertical alignment for London Rd. using the 
geometry tools. You will learn how to create, edit, annotate and review geometric elements. 
You will also learn how to attach an existing terrain model and aerial imagery as well as define 
2D and 3D views.



Geometry Overview

The geometry tools are a dynamic, interactive and rules-based approach to geometry. Civil Geometry or geometric rule-based elements are 
created intelligently as the tools are used and elements are constructed. 

Rule-based elements provide Design Intent that builds associations and relationships between civil elements. Object information (how, where, 
and by what method it was created) is stored with the object to insure the original intent is retained and honored in the design. If an element is 
modified, any related elements will recreate themselves based on these stored relationships. 

All Geometric data is stored directly in the dgn file and can be easily edited and reviewed via the drag handles, dynamic dimensions, text 
manipulators, etc.
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QuickStart for Geometry - Course Workflow

1. Select WorkSpace & WorkSet

2. Create 2D dgn file

3. Attach Aerial Image dgn

4. Create Horizontal Alignment

a. Set Active Feature Definition

b. Create Horizontal Elements: Lines and Arcs

c. Complex Horizontal Elements together

d. Define Stationing

e. Create and Review Geometry Report

f. Annotate Geometry

5. Attach Existing Terrain Model and Set as Active Terrain Model

6. Open 2D & 3D Views and Review Design File Models

7. Create Vertical Alignment

a. Define Profile Model View

b. Create Vertical Elements: Lines and Curves

c. Complex Vertical Elements together

d. Set Active Profile

e. Create and Review Geometry Report
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Exercise 1: Create a New File and Review the Interface

In this exercise, you will learn how to select a workspace and workset, create a new 2D design file, and review the 
ribbon interface.

Skills Taught
 Selecting a WorkSpace and WorkSet

 Create a 2D design file

 Review the Ribbon Interface
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Select the WorkSpace & WorkSet and Create a New 2D Design File

In this section, you will select the training workspace and workset, and create a new 2D design file. Always start in a 2D 
design file when creating and working with geometry.

1. Start the software.

2. Set the WorkSpace and WorkSet

The WorkSpace and WorkSet define standards that are used by the software. The WorkSpace and WorkSet used for this training are 
installed during the software installation.

a. Select Training and Examples from the WorkSpace menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet menu.

3. Create a new 2D design file.

a. Select New File.

b. Browse to c:\Bentley Training\QuickStart for Geometry - Road or other folder where you unzipped the dataset files.

c. Set the Seed to Seed2D - Imperial Training.dgn [Seed 2D - Metric Training.dgn].

d. Create a new file named Geometry.dgn [Metric-Geometry.dgn].
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Review the Interface

1. Select the OpenRoads Modeling workflow from the pick list in the upper left corner 
if it is not already active. 

The ribbon menu will change to OpenRoads Modeling tools. The tools are 
organized on Ribbon Tabs with the tools grouped into Categories on each tab.

 Home - Common tools such as Attributes, Explorer, Attach Reference Tools, Models, Level Display and Element Selection.

 Terrain - Element selection and terrain modeling tools.

 Geometry - Element selection, Civil AccuDraw and geometry tools.

 Corridors - Element selection, superelevation and corridor modeling tools.

 Model Detailing - Element selection, Civil Cells and 3D tools (Linear Templates, Surface Templates, etc.).

 Drawing Production - Element selection, saved views, notes, text, annotations, and plans production (cross section, plan, and 
profile) tools.

 Drawing - Commonly used MicroStation drawing tools. To access the complete set of MicroStation tools change the active 
workflow to Drawing, Modeling (3D file only) or Visualization (3D file only).

 View - Commonly used view control tools.
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2. Click on each of the Ribbon tabs and notice how each tab has a different set of Categories and tools.

3. Also note the tools to the right of the workflow drop down list. 
Tools such as Create New File, Open File, Save Settings 
Compress File, Undo, Redo, Print, Explorer and Properties can 
be found here.

A search ribbon tool is also available to assist with finding tools on the ribbon interface. When you are not sure where to find a tool on the 
ribbon interface simply key in the command in the Search Ribbon field and a search will be performed across all ribbon menus.
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4. Search for a tool using the search ribbon. Key in Arc in the Search Ribbon field.

5. Notice the results of the ribbon search are displayed in a dialog below the 
Search Ribbon field.

6. Hover over Arc Between Points.

The search results expand showing where the Arc Between Points tool is 
located on the ribbon: OpenRoads Modeling -> Geometry -> Horizontal -> Arcs

7. From the search results dialog, Left-click, Arc Between Points to launch the 
command.

8. Right-click to close the Arc Between Points toolbox.
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9. Introduction to the Back Stage View.

a. Activate the Back Stage View by clicking File in the ribbon menu.

b. Notice the various other options on this screen such New, Open, Save, Save settings, etc. Whenever you need to open a file or create 
a new file you will have to access the Back Stage View.

c. Select Settings.

Design File settings, preferences, customizations, etc. are found in the Back Stage View, keeping the ribbon menus focused on the 
tools.

d. Click the Arrow in the upper left corner to return to the main ribbon interface.
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Exercise 2: Creating Horizontal Geometry

In this exercise, you will learn how to create a horizontal alignment using the horizontal element tools.

Skills Taught
 Attach aerial imagery reference file

 Create horizontal geometric elements using the Place Line Between Points and Simple Arc tools

 Combine geometric elements into a complex element to create the horizontal alignment

 Review the geometric elements with the Model Explorer

 Define the start stationing of the horizontal alignment

 Create horizontal geometry report

 Annotate horizontal alignment
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Attach Reference File

Let’s first attach the Aerial_Topo.dgn [Metric-Aerial_Topo.dgn] as a reference file to your design file. The Aerial_Topo.dgn [Metric-
Aerial_Topo.dgn] file contains the PI locations that you will use to create the tangent elements of the alignment.

1. Attach Aerial_Topo.dgn [Metric-Aerial_Topo.dgn] as a reference.

a. Click on Home > Primary > Attach Tools and select References.

The References dialog will now appear as shown above. You use this dialog to attach reference files to design files.

b. In the References dialog, Click on Tools and choose Attach.
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c. The Attach Reference dialog will appear, browse to the location of Aerial_Topo.dgn [Metric-Aerial_Topo.dgn] and left-click on it.

d. Change the Attachment Method to Coincident World and then Click Open to attach the file as a reference.
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The Aerial_Topo.dgn [Metric-Aerial_Topo.dgn] will now be attached to the active file and 
displayed in the References Dialog.

e. Close the Reference dialog.

f. Click the Fit view icon so you can see all of the graphics in the design file.

g. Locate and review the PI points (magenta circles) drawn in the Aerial_Topo.dgn [Metric-
Aerial_Topo.dgn]. Notice there are 5 PI points, you will be creating tangent lines between 
these points.

TIP: The software also provides the ability to display a background map directly from Bing Maps. 
This option can be found under the View Attributes > Background Map panel.
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Create Horizontal Elements for London Rd.

In this section, you will be creating the horizontal alignment for London Rd. (see image to the 
right). London Rd. runs from south to north and is made up of 4 tangents and 3 curves. You will 
first define the tangents between PI points and then add horizontal curves.

1. Set a Feature Definition to be used with your geometric elements.

Feature Definitions are used to control symbology, annotation, and various other properties 
that are applied to the geometric elements. The feature definitions are used to:

 Define what the geometric elements actually are. What is being modeled such as 
curb, centerline, edge of pavement, etc.

 Control symbology in various views, including capability to define differing symbology 
in plan, profile, and 3D spaces

 Define terrain modeling attributes (spot, break line, void, etc.)

 Define surface display characteristics

Feature Definitions are defined and stored in a DGN library delivered with the WorkSpace.

a. Open the Feature Definition Toggle Bar tool by going to Geometry > General Tools > 
Standards > Feature Definition Toolbar.

b. Set the active feature to Geom_Baseline by pressing the down arrow.
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c. Click on the Use Active Feature Definition tool on the Feature Definition Toggle Bar to toggle it on.

Setting the Active Feature Definition ensures that all geometric elements created will have the selected feature definition assigned to 
them as you create geometric elements.

2. Prior to creating geometry, review the Civil Formatting options for the design file. Civil Formatting is used to control the formatting and 
precision of the design file settings. Coordinate format and precision as well as Station format and precision can be adjusted here.

a. Select File > Settings > File > Design File Settings > Civil Formatting

b. Close Design File Settings

c. Click the Arrow in the upper left corner to return to the main ribbon interface.
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3. Create the tangent lines between known PI points. Use the image to the right as a guide.

a. From the ribbon menu select Geometry > Horizontal > Lines > Line Between Points

Notice the heads up display attached to your cursor will be prompting you for a start point.

b. Left-click on the Center Snap tool. Be sure AccuSnap is enabled as shown below.

c. Snap to the center of PI#1 and Left click to accept. 

Hint: If you have trouble snapping to the center just approximate the center point and 
move on to the next step.

A Note About Snaps and Design Intent:

When you snap to elements, the software remembers how you snapped to elements and 
what type of snap was used. Thus, a relationship exists between the elements. This is an 
example of Design Intent. 

Design Intent builds associations and relationships between civil elements. Object 
information (how, where, and by what method it was created) is stored with the object to 
insure the original intent is retained and honored in the design. This is a very important 
concept to remember as you work with the product.
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The heads up prompt changes and gives you the option to key in the distance and/or direction as needed. Pressing the Right arrow or 
Left arrow on your keyboard will toggle between Distance and Line Direction input fields.

d. Define the Distance, key in 546.00 [166] in the Distance field and press Enter to lock the value.

e. Press the Right Arrow on your keyboard to switch to the Line Direction field.

f. In the Line Direction field, key in: N01^33'00"W, press Enter to lock the value.

g. Left-click to accept.

4. Select the Element Selection tool. The Element Selection tool is used to select elements so they can be edited or manipulated with other 
commands.
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5. Set the Element Selection tool to the individual mode by selecting the Individual and New icons in the Element Selection tool setting 
window.

a. Select the line you just created. 

Recall, geometric elements are rule-based elements that provide Design Intent. Notice the line has a distance and direction associated 
with it. The distance and direction represent the rules associated to the element.

Also, note the Drag Handles as well as the Text Manipulators (direction/distance) attached to the line. These provide the ability to 
quickly modify the line. If you need to modify the distance and/or direction you can simply click on distance/direction Text Manipulators 
and key in new values in the edit fields. You can use the Drag Handles to trim/extend, rotate or move the line.
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b. Hover your cursor over the beginning point of the line, the Drag Handle arrows will appear as well as the center point snap indicator. 

The Drag Handle arrows give you the ability to dynamically adjust the end point of the line. By selecting the Drag Handle arrows you 
can extend or trim the line and also change the location of the end point.

The center snap indicator shows that the beginning point of the line was placed by snapping to the center of the circle. This is an 
example of Design Intent. A relationship exists between the beginning point of the line and the circle. Be aware, if the circle is moved 
the line will move. If the circle is deleted the relationship will be removed but the line will remain. This is an important concept to 
understand with regards to snaps.

c. Next, Hover your cursor over the line for a few seconds. A context sensitive menu will appear giving you access to other tools related 
to the element. Context sensitive menus appear if you hover your cursor over OpenRoads Designer elements or objects.

d. Select the Properties tool and review the properties of the line.

Note that the line can be edited within the Properties dialog. The Length, Direction, 
Start Point, End Point, Feature Name and Feature Definition can all be modified within 
this dialog if needed.

e. Left-click anywhere in the view to de-select the line.
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6. Continue placing tangent lines.

a. Click the Chain Commands tool on the Feature Definition Toggle Bar. When the Chain 
Commands tool is enabled, the next element is automatically connected to the previous 
element without having to select the start point each time.

b. Re-select the Geometry > Horizontal > Lines > Line Between Points tool.

c. Snap to the end point of the first tangent line to place the start point of the second tangent 
line. 

d. Left-click to accept.

e. Left-click near the center of the circle at PI #3 to complete placing the tangent line between 
PI #2 and PI #3.

f. Left-click near the center of the at PI #4 to place the tangent line between PI #3 and PI #4.

g. Left-click near the center of the at PI #5 to place the tangent line between PI #4 and PI #5.

h. Right-click to complete.
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Your geometric elements should look like the image to the right once you have completed 
placing all tangent lines. 

7. Create horizontal curves between tangent lines using the Simple Arc tool.

a. From the ribbon menu select Geometry > Horizontal > Arcs > Arc Between Elements > 
Simple Arc

b. Following the heads up prompts, locate and select first tangent element (line between PI #1 
and PI #2).

c. Locate and select second tangent element (line between PI #2 and PI #3).

d. Define the arc Radius as 600 [183 m], press Enter to lock the value and Left-click to 
accept.

e. Set the Trim/Extend option to Both and Left-click to trim both tangent elements.

NOTE: In lieu of using the heads up prompts, you can also key in values in the dialog box 
but you still need to Left-click to accept the values entered.
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8. Create remaining curves for PI#3 and PI#4 using the same methods described in steps 7a. 
through 7e. on the previous page. The radius values are given below:

 Curve at PI#3 Radius =10000 [3048] (curve to the right). Take care when placing this 
curve, since it has a very flat radius. It must curve to the right.

 Curve at PI#4 Radius = 2100 [640] (curve to the left)

9. Modify the first horizontal curve radius.

a. Pick the Element Selection tool.

b. Select the first horizontal curve, notice the radius is displayed as 600 [183].

c. Left-click the 600 [183] value, an edit field will appear.

d. Key-in 700 [213] in the edit field and press Enter (or Left-click) to change the radius. 

The curve will update with the new radius and the tangent lines adjust automatically to 
maintain their relationship with the curve. This is another example of Design Intent and 
the rules and relationships that exist between civil geometry elements. The software 
remembers that the original curve was placed between the two tangents and when the 
radius value changed the geometry adjusted itself to maintain the geometric relationship.
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Now that you have all of your elements created, you need to combine them together into an alignment. You will do this by using the 
Complex By Elements tool.

10. Use Complex By Elements tool to create a horizontal alignment for London Rd.

a. From the ribbon menu select Geometry > Horizontal > Complex Geometry > Complex By Element

b. In the dialog box, set the following parameters:

 Method: Automatic 

 Maximum Gap: 0.100 [0.01]

 Name: LondonRd

c. Following the heads up prompts, 

 Locate First Element: Select the first tangent line (between PI#1 and PI#2) near the beginning

 Accept Complex: Left-click to accept and create the complex profile element

NOTE: Where you select the element is important. Each element has a midpoint. Notice when selecting 
the element near the start point an arrow appears pointing north, indicating the direction the alignment 
will be created. If you select the element near the end point, the arrow will change direction, pointing 
south and will not create the alignment in the proper direction.
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The completed complexed horizontal alignment should look like the image to the right. 
The alignment is made up of 4 tangents and 3 curves.

d. Hover over the alignment and select it to display the element information and the edit 
handles. Note that the full alignment is highlighted and is a complex element.
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Review Geometry with the Explorer Window

In this section, you will learn how to review geometry in the Explorer window. The Explorer window can be used to 
browse and manage data in the design file. You can also use it to search, zoom to and isolate data. All data is organized 
and displayed in the Explorer window. As the design progresses, the information is automatically created and updated.

1. Review geometric elements in the Explorer window.

a. Select Home > Primary > Explorer to display the Explorer window.

Expand the OpenRoads Model group by pressing the down arrow.

TIP: It is recommended to always have Explorer open when working in the software.
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Geometric elements associated with alignments are grouped under the Alignments category. To see which elements are part of the 
Alignments category simply click on the small arrow next to the category to expand the list.

b. Click the small arrow next to Alignments to expand the list to see next item in the list.

c. Click the small arrow next to Geom_Baseline to the expand the list (recall Geom_Baseline 
was the feature definition you used to create your geometry.

d. Select Complex Element: LondonRd, observe that the London Rd. alignment is highlighted in 
View 1. This is an example of how Explorer can be used to locate and select an alignment in 
the design file.

e. Right-click on Complex Element: LondonRd to review other tools related to the alignment. You can left-click on any item in the list to 
gain access to other tools that can be used.



Copyright © 2019 Bentley Systems, Incorporated 28DO NOT DISTRIBUTE - Printing for student use is permitted

f. Click the small arrow next to Complex Element: LondonRd to expand the list to see the geometric elements associated with the 
alignment. Continue to expand the list to see the details and dependencies.
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Create a Horizontal Geometry Report

1. In the Explorer window, right-click on Complex Element: London Rd. to access the Horizontal Geometry Report

2. Select Horizontal Geometry Report
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3. The Bentley Civil Report Browser dialog will appear and the report will be displayed. Review the report.

After reviewing the report you may want to adjust the precision and format of distances, angles, bearings, etc. You can easily adjust the 
report with the Format Options tool.
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4. Go to Tools > Format Options in the Bentley Civil Report Browser.

5. Change the Format Options as follows:

 Angular - Precision: 0

 Angular - Format: ddd^mm’ss.s”

 Slope - Format: 50%

 Station - Precision: 0.12 [0.123]

 Station - Format: ss+ss.ss [s+sss.ss]

 Direction - Precision: 0

 Direction - Format: ddd^mm’ss.s”

6. Close the Format Options window.
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7. Review the report to ensure the formatting has been adjusted.

8. Save the report.

a. In the Bentley Civil Report Browser window, select File > Save As.

 Browse to C:\Bentley Training\QuickStart for Geometry - Road or other folder where you unzipped the dataset files

 File name: key in HR-LondonRd

 Save as type: choose Doc File (*.doc).

 Click Save, to save the report.

NOTE: You can also print the report by going to File > Print or Right-click in the report window and choose Print.
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Review the Bentley Civil Report Browser

The list in the left pane of the Bentley Civil Report Browser dialog shows the different report categories and report types available. Clicking on 
each category will give you access to a list of report types known as XSL Style Sheets (or simply called Style Sheets). Each Style Sheet 
contains the formatting for how a report is displayed. Selecting a Style Sheet will display the report in the right portion of the dialog.
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Also, by right-clicking on a Style Sheet you can set that style sheet to be the default report display for a selected report type. As shown 
below, the default Style Sheet for Geometry (horizontal geometry) is HorizontalAlignmentReview.xsl. 

The default Style Sheets are stored in the registry by user and can be changed at any time. 
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View Other Horizontal Geometry Reports

1. If necessary, left-click the small arrow next to the Civil Geometry category to expand the 
report list to display available style sheet reports.

2. Select the HorizontalAlignmentCheckIntegrity.xsl style sheet.

3. Review the report.

4. Select several other Horizontal Alignment style sheets and review how the same alignment data is presented differently.

5. Close the Bentley Civil Report Browser.
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Define the Start Station

In this section, you will learn how to define the start station value and assign it to the horizontal alignment.

1. From the ribbon menu select Geometry > Horizontal > Modify > Start Station

2. Following the heads up prompts:

a. Locate Element: Select the London Rd. alignment.

b. Start Distance: 0, press Enter to lock the value and Left-click to accept.

c. Start Station: 50+00 [5+000], Left-click to accept.

3. Review the stationing

a. Click the Element Selection tool.

b. Select the alignment, notice the alignment displays the new beginning station value. The begin station is dynamic text which can be 
adjusted by simply selecting the begin station value and keying in a new value. The stationing of the alignment will then update.

c. Hover your cursor over the alignment until the context sensitive menu appears.

d. Select Horizontal Geometry Report to review the alignment again to verify the stationing.

e. Close the Bentley Civil Report Browser dialog box.

f. Left-click anywhere in View 1 to de-select the alignment.
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Annotate Horizontal Alignment

1. From the ribbon menu select Drawing Production > Drawing Scales > 
Annotation Scale Lock and set the scale to 1”=100’ [1:500]

2. From the ribbon menu select Drawing Production > Annotations > Element 
Annotation > Annotate Element

3. At the prompt Locate Elements - Reset to Complete, select the alignment and 
then right-click to complete.

The alignment is now annotated. The annotation is also dynamic and 
associated to the alignment. Any changes made to the alignment will update 
the annotation.

The annotation is defined by an Annotation Group which is associated with the 
Feature Definition. The text size is controlled by the Annotation Scale Lock.
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Exercise 3: Existing Terrain Model and Define 2D & 3D Views

Skills Taught
 Attach Terrain Model

 Set Terrain Model Active

 Define 2D & 3D Views

 Review Design File Models
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Attach Terrain Model

In this section, you will learn to attach a terrain model to your design file. Terrain models are stored in 3D design files. Any time you need to 
use a terrain model within your design file, you just need to attach the terrain model as a reference. 

1. Attach Terrain_Existing.dgn [Metric-Terrain_Existing.dgn] as a reference.

a. Click on Home > Primary > Attach Tools > References.

The References dialog will now appear as shown above. You use this dialog to attach reference files to dgn files.

b. From the References dialog, select the Attach 
Reference icon or Tools > Attach...

c. Select the file Terrain_Existing.dgn [Metric-
Terrain_Existing]

d. Set the Attachment Method to Coincident-World.

e. Click Open
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f. The terrain model, Terrain_Existing.dgn [Metric-Terrain_Existing.dgn] is now attached to the file. 

g. Close the References dialog box.

h. Click the Fit View icon in the top of the view window so you can see all of the graphics in the design file.

Notice the green shape that is now present in the design file. This green shape represents the boundary of the terrain model.

NOTE: For the purposes of this course we are not going to view the terrain model triangles or features.
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Setting the Active Terrain Model

1. Click the Element Selection tool

2. Set the Element Selection tool to the individual mode by selecting the Individual and New icons in the Element Selection tool setting 
window.

3. Left-click anywhere on the green shape that outlines the terrain model.

4. Hover the cursor at this location for a few seconds and context sensitive toolbar appears displaying tools commonly used with terrain 
models. More terrain model tools can be found on the Terrain ribbon menu.

5. Select the Set As Active Terrain Model tool.

Setting the terrain model active instructs the software to use the active terrain model as the default terrain model when using other 
OpenRoads Designer tools. You can always change or clear the active terrain model at any time.

Also, when setting the Active Terrain Model the software will automatically create a 3D model inside of your 2D design file. The 3D model 
will be used for the display of 3D data.
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Open 2D and 3D Views

1. Press F9 on your keyboard.

Notice the views change, you now have 2 view windows open. View 1 on the left is the 2D model view that you started with and View 2 on 
the right is the 3D model view. Pressing the F9 key automatically configures this particular view setup for you, 2D on the left and 3D on the 
right. This will come in handy as you move through the design process.

Also, observe the existing terrain model boundary is displayed in 2D and 3D. The terrain model triangles are not displayed at this time. 
Triangles, breaklines, feature spots and contours can be displayed via the terrain model properties as needed.
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2. Alternatively, in View 1 you can right-click and hold down the right mouse button to access special view control tools. 

a. Select View Control > 2 Views Plan/3D.

b. Click the Fit View icon in the top of the view windows so you can see all of the graphics in both views.
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Review Design File Models

1. From the ribbon menu select Home > Primary > Models

2. Review the Models dialog, notice there are 2 models available, Default and Default-3D. 

Models can be 2D or 3D. It’s very important to realize that even though you started with a 2D dgn file it is possible to have a 3D model 
also available in the same design file. Recall that setting a terrain model active automatically creates a 3D model for you. The 3D model 
must be created by the product. Do not create your own model named Default-3D, it will not work properly.

Also, the 2D and 3D models are directly related to the model views, recall View 1 is named Default and View 2 is named Default-3D.

3. Close the Models dialog.

4. Close the View 2.
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Exercise 4: Creating Vertical Geometry

In this section, you will learn how to create a vertical alignment using the vertical geometry tools.

Skills Taught
 Define Profile Model View

 Create vertical geometric elements using the Place Line Between Points and Parabola Between Elements tools

 Combine geometric elements into a complex element to create the vertical alignment

 Create a vertical alignment report
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Define Profile Model View

In this section, you will learn how to define a profile view. Prior to creating vertical geometry you must first define a 
profile model view to display the vertical geometry.

1. Maximize View 1 by clicking the maximize view icon in the view window.

2. Click the Fit View icon in the top of the view window so you can see all of the 
graphics in the design file.

3. Click the Element Selection tool.

4. Select the horizontal alignment. Hover your cursor over the alignment until the context sensitive menu appears.

5. Select the Open Profile Model icon, the heads up display will prompt you to Select or Open View.

6. Open View 4 by selecting the view 4 button from the views toggle menu at the bottom of the screen. Profiles can be displayed in any view.

7. Click inside of the View 4 window. View 4 is now defined as the profile model view. Only one profile model view can be active at a time.

8. In View 4, click Fit View. You should now see the existing ground profile (green dashed line).
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9. Select the Element Selection tool.

10. Select the existing ground profile line (green dashed line). 

11. Hover your cursor over the existing ground profile line until the context sensitive menu appears.

12. Click the Set As Active Profile icon to set the existing ground line as the active profile. 

Setting the existing ground profile active associates it with the horizontal alignment. It also draws the profile in the 3D model. This will be 
the default profile for now until you design the proposed vertical alignment. The active profile can be changed at any time.

13. In View 4, select View Attributes in the upper left corner of the view window.

14. Set the profile view Exaggeration to be 20.

Notice how the profile view dynamically adjusts itself to reflect the new vertical exaggeration. The vertical exaggeration can be changed at 
any time.

15. Click the Fit View icon again in View 4 to re-center the graphics.
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Create Vertical Geometry

In this section, you will be creating the vertical alignment for London Rd. (see image below). The vertical alignment is 
made up of 4 tangents and 3 vertical curves. You will first define the profile tangent lines and then add vertical curves.

1. Prior to placing elements, on the Feature Definition Toggle Bar ensure that 

 Active Feature Definition is still set to Alignment > Geom_Baseline 

 Use Active Feature Definition toggle is On

2. Click the Chain Commands tool on the Feature Definition Toggle Bar. 

When the Chain Commands tool is enabled the next element is automatically connected to the previous element without having to select 
the start point each time.

3. Select Geometry > General Tools > Civil Toggles > Civil Accudraw to display the Civil 
AccuDraw toggle bar. 

Civil AccuDraw is used for precision input with civil geometry and will be used to 
place profile elements by station and elevation.

a. Click the Toggle Civil AccuDraw icon on the toggle bar.

b. Click the Z (elevation) icon on the toggle bar. 
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4. Create first profile tangent line between PVI’s.

a. From the ribbon menu select Geometry > Vertical > Lines > Profile Line Between Points

a. Move your cursor into View 4, notice the heads up prompts for Station and Z (elevation). These are the Civil AccuDraw input fields.

b. In the Station field key in 50+00 [5+000] and press Enter. Notice the station value is now locked.

c. In the Z field key in 167.74 [50.7] and press Enter.

d. Left click to accept.

5. Continue following the heads up prompts to place the end point of the profile tangent line.

a. Key in 57+16.00 [5+218] in the Station field and press Enter.

b. Key in 172.31 [52.1] in the Z field and press Enter.

c. Left click to accept. The first tangent line is now placed.

Note the dynamic display showing the slope and length as you place the line. In addition to placing the line by station and elevation 
you can also place it using a length and slope.
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6. Select the Civil AccuDraw tool to turn off Civil AccuDraw. 

We will now place profile tangent elements by length and slope.

7. Follow the heads up prompt to place the next profile tangent #2

a. In the Length field enter 700 [213], press Enter to lock the value.

b. Press the right arrow to toggle to the Slope field and enter -2.0%, press Enter to lock the value.

c. Left-click to accept and move to the next prompt.

8. Create the remaining tangent elements (#3 and #4) using the previous step and the image below as a guide. If you are having trouble 
keying in values, you can approximate the lengths and slopes. If you make a mistake you can use the Undo button to get back to the 
previous steps.

9. After the last tangent line is placed, Right-click to complete.

10. Press the Esc key to exit the command.
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11. Review tangent lines.

a. Use the Element Selection tool and left-click on profile tangent line #1 and notice the slope and length are displayed as well as the 
Drag Handles and Text Manipulators. Clicking on the slope, length, station or elevation will enable you to enter new values at any time. 
Adjusting the Drag Handles will trim/extend or move the line.

b. Right-click to de-select the line or left-click anywhere in the view.

12. Review the remaining tangent lines using the procedures described in the above step.

13. Click the Fit View icon again in View 4 to re-center the graphics.

Define the Vertical Curves
14. Define a 300’ [91’ m] vertical curve between tangent lines #1 and #2.

a. Select Geometry > Vertical > Curves > Profile Curve Between Elements > Parabola Between Elements

b. Following the heads up prompts, select tangent line #1 and when prompted select tangent line #2.

(Be sure to keep your cursor below the tangent lines to ensure a crest curve will be created).

c. Following the heads up prompts, in the Length field key in 300 [91] and press Enter to lock the value.

d. Left-click to accept and move to the next prompt.

e. Set the Trim/Extend option to Both and left-click to complete the command.

A 300’ [91’ m] vertical curve is now placed between tangent lines #1 and #2.
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15. Define a vertical curve with a K value of 171.00 [52] between tangents #2 and #3.

The Geometry > Vertical > Curves > Profile Curve Between Elements > Parabola Between Elements tool should still be active, if not, re-
select it.

a. Following the heads up prompts, select tangent line #2 and when prompted select tangent line #3.

b. Following the heads up prompts, press the Left Arrow key to toggle to Vertical Curve Parameter.

c. Key in 171.00 [52] in the Vertical Curve Parameter field and press Enter to lock the value.

d. Left-click to accept and move to the next prompt.

e. Set the Trim/Extend option to Both and left-click to complete the command.

A vertical curve with a K value of 171.00 [52] is now placed between tangent lines #2 and #3.

16. Repeat step 14 and create a 400’ [122 m] vertical curve between tangent lines #3 and #4.

The completed vertical geometry elements should look like the image below.
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17. Modify vertical curve #1 length to be 400’ [122]

a. Select vertical curve #1, notice the curve length 300 [91] is displayed as well as the K 
value.

b. Left-click on the curve length value, enter 400 [122] in the edit field and press Enter.

The vertical curve updates and displays the new curve length and K value.

18. Group the London Rd. vertical geometry elements into a single complex element to create the vertical alignment.

a. Select the Geometry > Vertical > Complex Geometry > Profile Complex by Elements tool.

b. In the dialog box, set the following parameters:

 Method: Automatic 

 Maximum Gap: 0.100 [0.01]

 Name: LondonRd

c. Following the heads up prompts, 

 Locate First Element: Select tangent line #1 near the beginning and then left-click to accept it

 Accept Complex: Left-click to accept and create the complex profile element

d. Select the vertical (profile) alignment and note that all the elements are now a complex profile.
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19. Set the newly designed profile as the active profile.

a. Select the Element Selection tool.

b. Select the complex profile element and hover your cursor over it until the context sensitive menu appears.

c. Select the Set As Active Profile tool. 

The newly designed vertical alignment will now be the active vertical alignment associated with the horizontal alignment. A relationship 
now exists between the horizontal and vertical geometry. Be aware that deleting the horizontal geometry or dropping the horizontal 
geometry will impact the vertical geometry.

NOTE: Whenever you set the active profile a 3D alignment feature will automatically be displayed in 3D.
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Create the Vertical Geometry Report and View the Vertical Alignment in 3D

In this section, you will learn how to create a vertical geometry report and also how to view the vertical alignment in 3D.

1. Select the Element Selection tool.

2. Select the complex profile element and hover your cursor over 
it until the context sensitive menu appears.

3. Select the Profile Report tool.

4. Review the Vertical Alignment report and adjust the report formatting as needed using Tools > Format Options from the report dialog 
menu bar.

5. Close the report window and close the profile window, View 4.

Review the vertical alignment in the 3D view.

6. Press the F9 key to switch the view windows to display the 2D and 3D views. 

7. Alternatively, you can Right-click in View 1 and hold down the right mouse button to access special view control tools. 

a. Select View Control > 2 Views Plan/3D.

8. Click the Fit View icon in View 2. 

Notice a 3D element is displayed in the 3D view. This is the newly created vertical alignment shown in 3D.
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Summary

In this course you have learned how to attach an existing terrain model and aerial imagery to your design file as well as define 2D and 3D 
views. You have also learned how to create, edit, annotate and review geometric elements, and how to create horizontal and vertical 
alignments for London Rd. using the geometry tools.
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